How to upgrade RESTLET from 1.1-M4 to latest version

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

How to upgrade RESTLET from 1.1-M4 to latest version

Santhosh S
Hi,

I'm currently using restlet 1.1-M4 version. I want to upgrade it to version 1.1.10. Please suggest me how to do that. I did the following but did not work out. Please help me,

1. pom.xml file

<dependency>
             <groupId>org.restlet</groupId>
             <artifactId>org.restlet</artifactId>
             <version>1.1.10</version>
         </dependency>
         <dependency>
             <groupId>com.noelios.restlet</groupId>
             <artifactId>com.noelios.restlet.ext.servlet</artifactId>
             <version>1.1.10</version>
         </dependency>
         <dependency>
             <groupId>org.restlet</groupId>
             <artifactId>org.restlet.ext.json</artifactId>
             <version>1.1.10</version>
         </dependency>
         <dependency>
             <groupId>org.restlet</groupId>
             <artifactId>org.restlet.ext.fileupload</artifactId>
             <version>1.1.10</version>
         </dependency>
         <dependency>

2. Code update

  Router createRouter() {
      Router baseRouter = new Router();
      baseRouter.setDefaultMatchingMode(Template.MODE_STARTS_WITH);
      baseRouter.setDefaultMatchQuery(true);
      return baseRouter;
  }


But still, facing problem, request does not reaching to REST end point.


Thanks, 

Santhosh S

--
You received this message because you are subscribed to the Google Groups "Restlet Framework (Discuss)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].