(BUG) restlet-ext-jaxrs depends on a snapshot jax-rs (javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

(BUG) restlet-ext-jaxrs depends on a snapshot jax-rs (javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

Hendy Irawan-3
Restlet-ext-JAXRS depends on a snapshot jax-rs
(javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

My project is not buildable under this configuration. Using Maven 2.0.9.

1) javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT


  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=javax.ws.rs -DartifactId=jsr311-api
-Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file


  Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=javax.ws.rs -DartifactId=jsr311-api
-Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url]
-DrepositoryId=[id]


  Path to dependency:
        1) *
        2) org.restlet:org.restlet.ext.jaxrs:jar:1.1.1
        3) javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT

I've reported this as bug in
http://restlet.tigris.org/issues/show_bug.cgi?id=647


--
Best regards,
Hendy Irawan
"Help save my best friend Melissa from teeth infection, please!" ->
www.rainbowpurple.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: (BUG) restlet-ext-jaxrs depends on a snapshot jax-rs (javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

jlouvel
Administrator

Hi Hendy,

Thanks for the report, this has been fixed in SVN trunk and 1.1 branch. This
will be released in the upcoming 1.1.2 version.

Best regards,
Jérôme Louvel
--
Restlet ~ Founder and Lead developer ~ http://www.restlet.org
Noelios Technologies ~ Co-founder ~ http://www.noelios.com
 

-----Message d'origine-----
De : Hendy Irawan [mailto:[hidden email]]
Envoyé : samedi 8 novembre 2008 06:46
À : [hidden email]
Objet : (BUG) restlet-ext-jaxrs depends on a snapshot jax-rs
(javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

Restlet-ext-JAXRS depends on a snapshot jax-rs
(javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT).

My project is not buildable under this configuration. Using Maven 2.0.9.

1) javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT


  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=javax.ws.rs -DartifactId=jsr311-api
-Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file


  Alternatively, if you host your own repository you can deploy the file
there:
      mvn deploy:deploy-file -DgroupId=javax.ws.rs -DartifactId=jsr311-api
-Dversion=1.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url]
-DrepositoryId=[id]


  Path to dependency:
        1) *
        2) org.restlet:org.restlet.ext.jaxrs:jar:1.1.1
        3) javax.ws.rs:jsr311-api:jar:1.0-SNAPSHOT

I've reported this as bug in
http://restlet.tigris.org/issues/show_bug.cgi?id=647


--
Best regards,
Hendy Irawan
"Help save my best friend Melissa from teeth infection, please!" ->
www.rainbowpurple.com

Loading...